AWS DNS Intermittent Issues

Resolved

This incident has been resolved.
Posted Oct 23, 2019 - 08:37 CDT

Monitoring

AWS has identified the issue and is working on a fix. We will update the incident once we get the resolution signal from AWS.
Posted Oct 22, 2019 - 17:35 CDT

Identified

We want to give you information regarding the occasional DNS resolution errors that may impact the operation of Network360 downloads. The AWS DNS servers are currently under a DDoS attack. AWS DDoS mitigations are absorbing the vast majority of this traffic, but these mitigations are also flagging some legitimate customer queries at this time. We are actively working on additional mitigations, as well as tracking down the source of the attack to shut it down.

We are actively monitoring this issue and will update you as soon as the issue is resolved on AWS end, however at this moment I won't be able to provide an ETA.

WORKAROUND:
If you have a download link
https://n360-downloads.s3.amazonaws.com//somefile.pdf
You can edit the link to:
https://n360-downloads.s3.us-east-1.amazonaws.com//somefile.pdf
Posted Oct 22, 2019 - 16:42 CDT
This incident affected: Network360.